FIXED: RunKeeper integration broken

Asics made som unexpected changes to their services around February 9th, which unfortunately broke the RunKeeper integration. 

The issue was fixed in version 2.82 on the App Store.

Since Asics stopped providing 3rd party developers acces to their "Open Graph" API back in 2017, apps like RunGap have to rely on undocumented  methods and web-automation in order to keep the integration running. This is bound to break from time to time whenever their developers decide to modify their code. I will continue looking into this until it either works for all users (if possible) or RunKeeper no longer is supported by RunGap.

Thank you for your patience.

Have more questions? Submit a request

30 Comments

  • 0
    Avatar
    Dirk Cremer

    Thank you!

  • 4
    Avatar
    Dirk Cremer

    Unfortunately the RunKeeper API login fails although I updated to Version 2.82 🤷‍♂️
    What else can I do?
    Thank you!

  • 1
    Avatar
    nhwirth

    I am having the same issue. I updated the app to 2.82, but I am getting a “RunKeeper API Login Fail” error message.

  • 0
    Avatar
    こたポン

    me too

  • 0
    Avatar
    Toshiki Sakurama

    Same here T_T

  • 0
    Avatar
    Kristian Ottosen

    Whoops. Please give it another try and contact support@rungap.com if the issue persists.

  • 0
    Avatar
    Dirk Cremer

    I don‘t know what happend in the nighttime, but now I can log in… (iOS)

  • 1
    Avatar
    Kristian Ottosen

    An elf just sneaked in went in a fixed a script ;)

  • 0
    Avatar
    Peter

    Updating did not fix it for me. I had to logout from Runkeeper in RunGap and then re-connect/login to make it work.

    Edit: ok, that was short. Worked only once. Can not sync data to Runkeeper. Getting a login error now too.

    Edited by Peter
  • 0
    Avatar
    Peter

    Did some testing. I can login into Runkeeper. However, I can not sync any activities to Runkeeper. When trying to sync data to Runkeeper, I get a login error. Even when it’s already connected.

  • 0
    Avatar
    Alfred Yates

    I am encountering the same as Peter is stating. Seemed to synchronize once, and can log in successfully, but will not sync any other runs. I can logout and then back in with Rungap using Runkeeper credentials, but does not seem to upload after the very first time.

  • 0
    Avatar
    Kristian Ottosen

    The analytics reveals that the number of workouts being imported from and exported to RunKeeper is back to normal and I have not received new reports since the last fix yesterday morning.

    Please double check that you have version 2.82, the most recent iOS version and try to shut down and restart your device.

    Contact support@rungap.com if the issue persists.

  • 0
    Avatar
    Peter

    I have found my problem. My VPN connection blocked the export to Runkeeper. When I turn of the VPN, it’s working perfectly. :-)

  • 0
    Avatar
    Smpenner Cpa

    Same as many of the others above, my export to Runkeeper worked perfectly until this morning when RunGap was upgraded to 2.82. I tried "forgetting" Runkeeper and re-logging in but zip. Tried one more time now the RunGap app is frozen entirely. 
    Discovered temporary alternative until Kristian is back and up and about (all the best!) - I am using HealthFit app linked to Apple Health. A bit cumbersome because you then have to log into Runkeeper website and upload the *.fit file but I can handle that for a few days/week or so if needed,

    Edited by Smpenner Cpa
  • 0
    Avatar
    Kristian Ottosen

    Thank you for your feedback.

    Since Asics stopped providing 3rd party developers acces to their "Open Graph" API back in 2017, apps like RunGap have to rely on undocumented  methods and web-automation in order to keep the integration running. This is bound to break from time to time whenever their developers decide to modify their code.

    I will continue looking into this until it either works for all users (if possible) or RunKeeper no longer is supported by RunGap.

    This is an uphill battle and it may take a while.

    Thank you for your patience.

    Edited by Kristian Ottosen
  • 0
    Avatar
    Alfred Yates

    Kristian,

    Thank you for the update!

  • 0
    Avatar
    Kristian Ottosen

    I just updated some scripts to better handle language settings during login.
    Please give it another try.

  • 0
    Avatar
    Smpenner Cpa

    Mine works now! Thank you.

  • 0
    Avatar
    Indy1911

    Unfortunately mine still isn’t working. Do I need to download a new version? I tried logging out of my RK and reconnecting. So no luck. So frustrating.

  • 0
    Avatar
    Alfred Yates

    Mine is working now too!

    Thank you, Kristian! 

  • 0
    Avatar
    ian_m_miller

    I can synchronize activities from Runkeeper to Rungap but I get a logon error when I share an activity from Rungap to Runkeeper. Any ideas?

  • 0
    Avatar
    ian_m_miller

    It worked today. Might have been sunspots or maybe a magic elf fixed
    it overnight.

  • 0
    Avatar
    Xetlim

    Seems like it’s broken again, tried both yesterday and today to upload to Runkeeper from Rungap without success :(

  • 0
    Avatar
    ian_m_miller

    Yeah, me too. Yesterday seems to have been a fluke. Another login error today. 

  • 0
    Avatar
    Smpenner Cpa

    Since my "swag bag" renewal yesterday my export to Runkeeper is broken again, too. (Now works, thanks!!)

    Edited by Smpenner Cpa
  • 0
    Avatar
    Kristian Ottosen

    Thank you for taking the time to report this (again)

    I just updated the scripts as needed and I believe that it is now working again.

  • 0
    Avatar
    Xetlim

    Thank you, it works again! :)

  • 0
    Avatar
    ian_m_miller

    It appeared to need to think about it, but it worked eventually.  Thanks!

  • 0
    Avatar
    Claudio Goncalvesjr

    Is anyone having an issue with exporting to Runkeeper? I am getting a login failed message.

  • 0
    Avatar
    Peter

    No issues here. Works just fine.

Please sign in to leave a comment.
Powered by Zendesk